Opened 11 years ago

Closed 6 years ago

#120 closed defect (fixed)

Reproduce my namelist.input

Reported by: ypsun Owned by: MarkelGarcia
Priority: major Milestone:
Component: WRF4G Keywords: namelist
Cc: antonio, chus, valva, lluis

Description

I'm trying to reproduce my WRF task using wrf4g.
I used your NI, NIN and NIM mechanism in experiment.wrf4g to set namelist parameters. However, after wrf4g_prepare and I check namelist.input under $WRF4G_BASEPATH and I found that it not the same as I want namelist.input.

On the other hand, wrf fdda option seems all failed to produce and there are also other options can not be read.

I upload some files for you to check:
experiment.wrf4g --> experiment.wrf4g in wrf4g
namelist.input.wrf4g --> namelist.input generate by wrf4g
namelist.input.my --> Original namelist.input generated on my computer
prepare.log --> Log of wrf4g_prepare

Attachments (1)

files.tgz (3.9 KB) - added by ypsun 11 years ago.

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by ypsun

comment:1 Changed 11 years ago by antonio

  • Cc chus valva lluis added
  • Owner changed from valva to MarkelGarcia
  • Status changed from new to assigned

Markel,

Can you look at the problem is having Yun-Pin?

It appears an issue with the fortnml tool.

Please look at the attached file for a log output of the problem.

Antonio

comment:2 Changed 11 years ago by MarkelGarcia

I find 2 issues in that experiments.wrf4g file:

-Namelist variables not present in the default namelist.input must be written appending "__(namelist section)" to them.

For example: NIM_grid_fdda = 1,0, must be NIM_grid_fdda__fdda = 1,0,

-fortnml does not parse well variables defined as .true. or .false. because of the points. This can be solved just quoting then. ".true.", ".false."

I also see that you define a bunch of variables that are already defined with the same vale in the default namelist. What fortnml does is just modifying this default namelist, so you don't need to add all this variables. WRF4G also writes by himself the proper start and ending dates, the resolution, etc.

You can read the default namelist.input by looking into the WRF binaries tar that you are using. For example, for me now it would be:

tar -xOzvf ${WRF4G_LOCATION}/repository/apps/WRFbin-3.3.1_r1206INTEL_OMPI.tar.gz WRFV3/run/namelist.input

If after fixing this issues you still find problems please let us know.

Markel

comment:3 Changed 6 years ago by carlos

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.