Opened 7 years ago

Closed 7 years ago

#1978 closed defect (fixed)

Error in retrieving system4 data

Reported by: matteo.defelice@… Owned by:
Priority: major Milestone:
Component: UserDataGateway Keywords:
Cc:

Description

years = 1990:2000;
lonlim = c(-10, 40)
latlim = c(10,60)
months = 6

s4 = loadECOMS(dataset = "System4_seasonal_15", var = 'rsds',

lonLim = lonlim, latLim = latlim, season = months,
years = years, time = "DD", leadMonth = 1)

[2014-09-11 15:20:08] Defining homogeneization parameters for variable "rsds"
[2014-09-11 15:20:09] Defining geo-location parameters
[2014-09-11 15:20:09] Defining initialization time parameters
[2014-09-11 15:20:09] Retrieving data subset ...
opendap.dap.DataReadException?: Inconsistent array length read: 1165128303 != 1914731274

at opendap.dap.DVector.deserialize(DVector.java:249)
at opendap.dap.DataDDS.readData(DataDDS.java:134)
at opendap.dap.DConnect2$DataDDSCommand.process(DConnect2.java:847)
at opendap.dap.DConnect2.openConnection(DConnect2.java:304)
at opendap.dap.DConnect2.getData(DConnect2.java:826)
at opendap.dap.DConnect2.getData(DConnect2.java:1116)
at ucar.nc2.dods.DODSNetcdfFile.readDataDDSfromServer(DODSNetcdfFile.java:1485)
at ucar.nc2.dods.DODSNetcdfFile.readData(DODSNetcdfFile.java:1656)
at ucar.nc2.Variable.reallyRead(Variable.java:879)
at ucar.nc2.Variable._read(Variable.java:865)
at ucar.nc2.Variable.read(Variable.java:677)
at ucar.nc2.dataset.VariableDS.reallyRead(VariableDS.java:553)
at ucar.nc2.dataset.VariableDS._read(VariableDS.java:533)
at ucar.nc2.SectionReader?.reallyRead(SectionReader?.java:61)
at ucar.nc2.dataset.VariableDS._read(VariableDS.java:503)
at ucar.nc2.dataset.VariableDS._read(VariableDS.java:527)
at ucar.nc2.Variable.read(Variable.java:677)
at ucar.nc2.Variable.read(Variable.java:623)
at ucar.nc2.dt.grid.GeoGrid?.readDataSlice(GeoGrid?.java:607)
at sun.reflect.GeneratedMethodAccessor17.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl?.invoke(DelegatingMethodAccessorImpl?.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at RJavaTools.invokeMethod(RJavaTools.java:386)

opendap.dap.DAP2Exception: opendap.dap.DataReadException?: Inconsistent array length read: 1165128303 != 1914731274

at opendap.dap.DConnect2.openConnection(DConnect2.java:308)
at opendap.dap.DConnect2.getData(DConnect2.java:826)
at opendap.dap.DConnect2.getData(DConnect2.java:1116)
at ucar.nc2.dods.DODSNetcdfFile.readDataDDSfromServer(DODSNetcdfFile.java:1485)
at ucar.nc2.dods.DODSNetcdfFile.readData(DODSNetcdfFile.java:1656)
at ucar.nc2.Variable.reallyRead(Variable.java:879)
at ucar.nc2.Variable._read(Variable.java:865)
at ucar.nc2.Variable.read(Variable.java:677)
at ucar.nc2.dataset.VariableDS.reallyRead(VariableDS.java:553)
at ucar.nc2.dataset.VariableDS._read(VariableDS.java:533)
at ucar.nc2.SectionReader?.reallyRead(SectionReader?.java:61)
at ucar.nc2.dataset.VariableDS._read(VariableDS.java:503)
at ucar.nc2.dataset.VariableDS._read(VariableDS.java:527)
at ucar.nc2.Variable.read(Variable.java:677)
at ucar.nc2.Variable.read(Variable.java:623)
at ucar.nc2.dt.grid.GeoGrid?.readDataSlice(GeoGrid?.java:607)
at sun.reflect.GeneratedMethodAccessor17.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl?.invoke(DelegatingMethodAccessorImpl?.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at RJavaTools.invokeMethod(RJavaTools.java:386)

Caused by: opendap.dap.DataReadException?: Inconsistent array length read: 1165128303 != 1914731274

at opendap.dap.DVector.deserialize(DVector.java:249)
at opendap.dap.DataDDS.readData(DataDDS.java:134)
at opendap.dap.DConnect2$DataDDSCommand.process(DConnect2.java:847)
at opendap.dap.DConnect2.openConnection(DConnect2.java:304)
... 19 more

Sep 11, 2014 3:24:41 PM ucar.nc2.dt.grid.GeoGrid? readDataSlice
SEVERE: GeoGrid?.getdataSlice() on dataset ssrd dods://www.meteo.unican.es/tds5/dodsC/system4/System4_Seasonal_15Members.ncml
java.io.IOException: opendap.dap.DataReadException?: Inconsistent array length read: 1165128303 != 1914731274

at ucar.nc2.dods.DODSNetcdfFile.readData(DODSNetcdfFile.java:1662)
at ucar.nc2.Variable.reallyRead(Variable.java:879)
at ucar.nc2.Variable._read(Variable.java:865)
at ucar.nc2.Variable.read(Variable.java:677)
at ucar.nc2.dataset.VariableDS.reallyRead(VariableDS.java:553)
at ucar.nc2.dataset.VariableDS._read(VariableDS.java:533)
at ucar.nc2.SectionReader?.reallyRead(SectionReader?.java:61)
at ucar.nc2.dataset.VariableDS._read(VariableDS.java:503)
at ucar.nc2.dataset.VariableDS._read(VariableDS.java:527)
at ucar.nc2.Variable.read(Variable.java:677)
at ucar.nc2.Variable.read(Variable.java:623)
at ucar.nc2.dt.grid.GeoGrid?.readDataSlice(GeoGrid?.java:607)
at sun.reflect.GeneratedMethodAccessor17.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl?.invoke(DelegatingMethodAccessorImpl?.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at RJavaTools.invokeMethod(RJavaTools.java:386)

Error in .jcall("RJavaTools", "Ljava/lang/Object;", "invokeMethod", cl, :

java.io.IOException: opendap.dap.DataReadException?: Inconsistent array length read: 1165128303 != 1914731274

Change History (2)

comment:1 Changed 7 years ago by juaco

Dear Mateo,

This is a temporary problem. Please try again after a while.
Many thanks for reporting

Joaquín

comment:2 Changed 7 years ago by juaco

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.