Opened 8 years ago

Closed 5 years ago

#290 closed enhancement (deprecated)

If no new filtar has been added to the request the 'Add parameter' is querying to the index node

Reported by: antonio Owned by: terryk
Priority: major Milestone: ESGFToolsUIPanel_v1.0
Component: ESGFToolsUIPanel Keywords:
Cc:

Description

If I'm not selecting a new parameter on the parameter tab, the 'Add Parameter' button is firing the event of query to index node.

I think it needs to be more smart.

Change History (4)

comment:1 Changed 8 years ago by terryk

I can't understand what is refered like "parameter tab" in ESGF Panel.

If you mean the category tree on the left in panel or the combo box of parameters that is below free text input.

In the first, i understand that the problem is that if there isn't changes in current parameters then the state of program must not been updated. In the second, i can't understand the problem.

comment:2 Changed 8 years ago by antonio

Yes, I'm refering the "category tree".

What I want to say is that if you click "Add Parameter" button the query is executed always it isn'r smarte enough to discover that no changes in selecting categories has been made.

P.S.: If the panel is category tree, why you put the parameter on the button "Add Parameter". It should be more meaning like add filter? or category?


comment:3 Changed 8 years ago by antonio

  • Milestone set to ESGFToolsUIPanel v1.0

comment:4 Changed 5 years ago by vegasm

  • Resolution set to deprecated
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.