Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#5982 closed enhancement (fixed)

Implement in Python the management of public keys

Reported by: minondoa Owned by: minondoa
Priority: major Milestone: DRM4G-2.5.1
Component: DRM4G Keywords: drm4g, ssh-copy-id, public key
Cc: carlos

Description (last modified by minondoa)

Almost every linux distribution comes with their own implementation of ssh-copy-id, which installs a public key into a remote machine's authorized_keys.
Right now we have an implementation packaged in the DRM4G, since not all versions work the same way, but the problem is that this one won't necessarily work on all distributions. So we need to implement our own way of managing it.

Change History (3)

comment:1 Changed 5 years ago by minondoa

  • Description modified (diff)
  • Keywords ssh-copy-id added; ssh-id-copy removed

comment:2 Changed 5 years ago by minondoa

  • Description modified (diff)
  • Milestone set to DRM4G multiplexing openssh
  • Resolution set to fixed
  • Status changed from new to closed

comment:3 Changed 5 years ago by minondoa

  • Milestone changed from DRM4G_multiplexing_openssh to DRM4G-2.5.1

Milestone renamed

Note: See TracTickets for help on using tickets.