Opened 5 years ago

Closed 5 years ago

#6006 closed enhancement (fixed)

Delete unused socket directory

Reported by: minondoa Owned by: minondoa
Priority: minor Milestone: DRM4G-2.6.1
Component: DRM4G Keywords: drm4g, socket directory
Cc:

Description (last modified by minondoa)

When using openssh as the communicator, the DRM4G will create the folder $DRM4G_DIR/.drm4g/var/sockets. Here will be the socket files that will be used to make the ssh connection. However, if the first chosen path for the socket files is too long (more than 108 characters in Unix systems or 104 in MacOS), it's changed for ~/.ssh/drm4g.
The problem is it doesn't erase the old folder.
Delete the old socket directory if it's empty.

Change History (5)

comment:1 Changed 5 years ago by minondoa

  • Description modified (diff)

comment:2 Changed 5 years ago by minondoa

  • Milestone changed from DRM4G_VO_management to DRM4G_VO

Milestone renamed

comment:3 Changed 5 years ago by minondoa

  • Milestone changed from DRM4G_VO to DRM4G-2.6.0

Milestone renamed

comment:4 Changed 5 years ago by minondoa

  • Milestone changed from DRM4G-2.6.0 to DRM4G-2.6.1

comment:5 Changed 5 years ago by minondoa

  • Resolution set to fixed
  • Status changed from new to closed

When using OpenSSH as the communicator, if the DRM4G has to change the socket directory, it will attempt to delete the old one.

  • This means that it will only delete it if the directory is empty.
Note: See TracTickets for help on using tickets.