Opened 5 years ago

Last modified 5 years ago

#6084 new defect

Fallo gw_im

Reported by: minondoa Owned by: carlos
Priority: critical Milestone: DRM4G-X.X.X
Component: DRM4G Keywords: drm4g, log, debug
Cc: minondoa, antonio, carlos

Description

Me está saliendo un fallo raro en el log del gwd.

    antonio@diluvio:~/virtualenv_drm4g/small_modifications$ tail -n 20 conf/.drm4g/var/gwd.log
    Fri Dec 16 15:23:04 2016 [IM][E]: MONITOR error in MAD (im_drm4g): acloud_147.228.242.94 -
    Fri Dec 16 15:23:05 2016 [IM][W]: Updating host "CESNET_Metacloud_147.228.242.94" with values of host "stoor94".
    Fri Dec 16 15:23:05 2016 [IM][W]: Updating host "CESNET_Metacloud_147.228.242.94" with values of host "stoor94".
    Fri Dec 16 15:23:05 2016 [IM][E]: Wrong field number in MAD (im_drm4g) message: None
    .
    Fri Dec 16 15:23:05 2016 [IM][E]: MONITOR error in MAD (im_drm4g): ne -
    Fri Dec 16 15:23:05 2016 [IM][W]: Updating host "localmachine" with values of host "diluvio".
    Fri Dec 16 15:23:05 2016 [IM][W]: Updating host "localmachine" with values of host "diluvio".
    Fri Dec 16 15:23:05 2016 [IM][E]: Wrong field number in MAD (im_drm4g) message: None
    .
    Fri Dec 16 15:23:07 2016 [IM][E]: MONITOR error in MAD (im_drm4g): acloud_147.228.242.94 -
    Fri Dec 16 15:23:08 2016 [IM][W]: Updating host "CESNET_Metacloud_147.228.242.94" with values of host "stoor94".
    Fri Dec 16 15:23:08 2016 [IM][W]: Updating host "CESNET_Metacloud_147.228.242.94" with values of host "stoor94".
    Fri Dec 16 15:23:08 2016 [IM][E]: Wrong field number in MAD (im_drm4g) message: None
    .

Y al hacer las pruebas del gw_im_mad_drm4g.py los mensajes se repiten. Por ejemplo yo solo ejecute una vez e monitor, pero me lo repitio:

    monitor 0 CESNET_Metacloud_147.228.242.94 -
    monitor 0 CESNET_Metacloud_147.228.242.94 -
    Opening ssh connection ...
    Trying ssh-agent ...
    Starting ssh-agent ...
      ssh-agent is already running
    Reading '/home/antonio/virtualenv_drm4g/small_modifications/conf/.drm4g/var/agent.conf' file
    Error trying to connect to '147.228.242.94'
    Impossible to load '/home/antonio/.ssh/id_rsa' key from the ssh-agent
    'ssh-agent' is running but without any keys
    Trying '/home/antonio/.ssh/id_rsa' key ...
    Connecting to '147.228.242.94' as user 'drm4g_admin' port  '22' ...
    Connected (version 2.0, client OpenSSH_6.6.1p1)
    Authentication (publickey) successful!
    MONITOR 0 SUCCESS HOSTNAME="stoor94" ARCH="x86_64" OS_NAME="GNU/Linux" OS_VERSION="3.13.0-101-generic" CPU_MODEL="NULL" CPU_MHZ=0 CPU_FREE=0 CPU_SMP=0 NODECOUNT=0 SIZE_MEM_MB=0 FREE_MEM_MB=0 SIZE_DISK_MB=0 FREE_DISK_MB=0 FORK_NAME="NULL" LRMS_NAME="fork" LRMS_TYPE="fork" FIXED_PRIORITY="0" QUEUE_NAME[0]="default" QUEUE_NODECOUNT[0]=0 QUEUE_FREENODECOUNT[0]=0 QUEUE_MAXTIME[0]=0 QUEUE_MAXCPUTIME[0]=0 QUEUE_MAXCOUNT[0]=0 QUEUE_MAXRUNNINGJOBS[0]=5 QUEUE_MAXJOBSINQUEUE[0]=5 QUEUE_STATUS[0]="NULL" QUEUE_DISPATCHTYPE[0]="NULL" QUEUE_PRIORITY[0]="NULL" QUEUE_NAME[1]="" QUEUE_NODECOUNT[1]=0 QUEUE_FREENODECOUNT[1]=0 QUEUE_MAXTIME[1]=0 QUEUE_MAXCPUTIME[1]=0 QUEUE_MAXCOUNT[1]=0 QUEUE_MAXRUNNINGJOBS[1]=0 QUEUE_MAXJOBSINQUEUE[1]=0 QUEUE_STATUS[1]="NULL" QUEUE_DISPATCHTYPE[1]="NULL" QUEUE_PRIORITY[1]="NULL"
    MONITOR 0 SUCCESS HOSTNAME="stoor94" ARCH="x86_64" OS_NAME="GNU/Linux" OS_VERSION="3.13.0-101-generic" CPU_MODEL="NULL" CPU_MHZ=0 CPU_FREE=0 CPU_SMP=0 NODECOUNT=0 SIZE_MEM_MB=0 FREE_MEM_MB=0 SIZE_DISK_MB=0 FREE_DISK_MB=0 FORK_NAME="NULL" LRMS_NAME="fork" LRMS_TYPE="fork" FIXED_PRIORITY="0" QUEUE_NAME[0]="default" QUEUE_NODECOUNT[0]=0 QUEUE_FREENODECOUNT[0]=0 QUEUE_MAXTIME[0]=0 QUEUE_MAXCPUTIME[0]=0 QUEUE_MAXCOUNT[0]=0 QUEUE_MAXRUNNINGJOBS[0]=5 QUEUE_MAXJOBSINQUEUE[0]=5 QUEUE_STATUS[0]="NULL" QUEUE_DISPATCHTYPE[0]="NULL" QUEUE_PRIORITY[0]="NULL" QUEUE_NAME[1]="" QUEUE_NODECOUNT[1]=0 QUEUE_FREENODECOUNT[1]=0 QUEUE_MAXTIME[1]=0 QUEUE_MAXCPUTIME[1]=0 QUEUE_MAXCOUNT[1]=0 QUEUE_MAXRUNNINGJOBS[1]=0 QUEUE_MAXJOBSINQUEUE[1]=0 QUEUE_STATUS[1]="NULL" QUEUE_DISPATCHTYPE[1]="NULL" QUEUE_PRIORITY[1]="NULL"

¿Puede ser algo del log que este volviendo a interferir?

Antonio

Change History (4)

comment:1 Changed 5 years ago by minondoa

Solo sucede en la rama "small_modifications" al poner todo en el "logger.conf" a DEBUG.

comment:2 Changed 5 years ago by minondoa

  • Keywords drm4g log debug added

I just updated the "small_modifications" branch in the GitBucket repository

comment:3 Changed 5 years ago by minondoa

  • Milestone changed from DRM4G-2.6.1 to DRM4G-2.6.2

comment:4 Changed 5 years ago by minondoa

  • Milestone changed from DRM4G-2.6.2 to DRM4G-X.X.X
Note: See TracTickets for help on using tickets.