Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#6105 closed task (fixed)

Editing non-existent configuration files

Reported by: minondoa Owned by: minondoa
Priority: major Milestone: DRM4G-2.6.5
Component: DRM4G Keywords: drm4g, configuraion, edit
Cc: carlos

Description

The command drm4 resource edit is available even if the drm4g is stopped, but only if the configuration folder ".drm4g" exists. The problem is that if the resource configuration file were to be deleted for any reason, the command would fail.
Prompt a message warning the user to run the command drm4g start --clear-conf to restore it.

Do the same for the commands drm4g conf ( daemon | sched | cloud | logger ), although they won't fail if the file doesn't exist, they just open a new empty file.

Change History (2)

comment:1 Changed 5 years ago by minondoa

  • Resolution set to fixed
  • Status changed from new to closed
  • Summary changed from Editing non-existant configuration files to Editing non-existent configuration files

comment:2 Changed 5 years ago by minondoa

  • Milestone set to DRM4G-2.6.5
Note: See TracTickets for help on using tickets.