WikiPrint - from Polar Technologies

Installation

The latest versions (stable and/or devel) can be installed directly from ?gitHub, but please note that the R package ?devtools must be installed first to ease the installation process.

First check that devtools is installed on your system, otherwise install it by typing:

if (!require("devtools")) install.packages("devtools")

Then, the loadeR.ECOMS package and associated dependencies are installed by entering the following command (it is important to preserve the ordering of the arguments):

devtools::install_github(c("SantanderMetGroup/loadeR.java",
                           "SantanderMetGroup/loadeR",
                           "SantanderMetGroup/loadeR.ECOMS"))

If attempting the installation from a proxy server and getting an error, please ?try this.

Alternatively, you can directly download the sources of the three packages for a local installation from their respective pages:

  1. ?loadeR.java
  2. ?loadeR
  3. ?loadeR.ECOMS

Again, bear in mind that order matters, and need to be preserved during installation.

In case installation problems arise related to your java configuration, please refer to this ?loadeR's wiki section for guidance.

Versions

A history of all package releases until the most recent is available on the ?loadeR.ECOMS releases page

loadeR.ECOMS supersedes the older package ecomsUDG.Raccess, which is no longer maintained. This is an historic of old versions:

?Older versions of ecomsUDG.Raccess (deprecated)

Development version

The development version is available at the 'devel' branch of the ??loadeR.ECOMS gitHub repository, but please note that the development version is unstable and may not be always functional